12 April, 2020

Liferay 7.3 compatibility matrix

Compatibility Matrix

Liferay's general policy is to test Liferay Portal CE against newer major releases of operating systems, open source app servers, browsers, and open source databases (we regularly update the bundled upstream libraries to fix bugs or take advantage of new features in the open source we depend on).
Nothing has been removed from the matrix, however a couple things have changed.  Liferay Portal 7.3 CE was tested extensively for use with the following Application/Database Servers:
Application Server
  • Tomcat 9.0
  • Wildfly 16.0 (Previously 11.0)
Database
  • HSQLDB 2 (only for demonstration, development, and testing)
  • MySQL 5.7, 8.0
  • MariaDB 10.2
  • PostgreSQL 11.2 (Previously 10)
JDK

  • IBM J9 JDK 8
  • Oracle JDK 8
  • Oracle JDK 11
  • All Java Technical Compatibility Kit (TCK) compliant builds of Java 11 and Java 8

Rate Me:

Liferay 7.3 compatibility matrix

Compatibility Matrix Liferay's general policy is to test Liferay Portal CE against newer major releases of operating systems, open s...